PHP 7.1.21 and 7.2.9

The PHP developers recently released versions 7.1.21 and 7.2.9 that fix several bugs. We’ve upgraded the PHP 7.1 and 7.2 series on our servers as a result.

These changes should not be noticeable, but as always, don’t hesitate to contact us if you have any trouble.

phpMyAdmin updated to version 4.8.3

We’ve updated phpMyAdmin to the latest version, 4.8.3.

Read the rest of this entry »

PHP 5.6.37, 7.0.31, 7.1.20 and 7.2.8

The PHP developers recently released versions 5.6.37, 7.0.31, 7.1.20, and 7.2.8 that fix several bugs. We’ve upgraded the PHP 5.6, 7.0, 7.1, and 7.2 series on our servers as a result.

These changes should not be noticeable, but as always, don’t hesitate to contact us if you have any trouble.

HTTP/2 support for all sites (completed)

Update June 13, 2018: This is complete, and HTTP/2 is now used on all websites we host.

We’ve updated the Apache web server software we use from version 2.4.25 to 2.4.33, which allows us to add support for the newer HTTP/2 protocol.

HTTP/2 is enabled for our own tigertech.net sites and a small number of our customer sites now, and we’ll be gradually rolling out this feature to all sites over the next few weeks. (We’ll update this post when that’s completely finished.)

Customers should not see any problems or downtime. We’re mentioning it here just so that customers who do notice a change for some reason will know about it. As always, don’t hesitate to contact us if you have any trouble.

Read the rest of this entry »

Apache 2.4.25 web server upgrade (completed)

Update May 22, 2018: The change described below is complete on all servers.

Over the next few days, we’ll be updating the software used on each web server from Apache version 2.4.10 to 2.4.25.

Customers should not notice any changes or downtime. We’re mentioning it here just so that customers who do notice a change for some reason will know about it.

This is part of a series of software upgrades to allow us to add support for the newer HTTP/2 protocol on all sites in the near future.

As always, don’t hesitate to contact us if you have any trouble.

PHP versions < 5.6 rebuilt (but please don't use them any more)

Although we haven’t offered the long-obsolete PHP 5.5 (and earlier) series to new customers for some time, some customers who signed up long ago are still using this version (or even earlier versions), despite our nagging you to upgrade 🙂

For those customers still using PHP 5.5 or earlier despite the nagging, this is just a quick note that we’ve “rebuilt” older versions of PHP for technical reasons to allow them to keep running on our systems. They now use slightly newer versions of various libraries, including libxml, FreeType, ImageMagick, MySQL, and OpenSSL, and they no longer support some old obsolete libraries, such as T1Lib. The rebuilt version will be deployed on all our servers within the next few hours.

These changes should not be noticeable. In the unlikely event you experience any trouble, don’t hesitate to contact us.

Read the rest of this entry »

PHP 5.6.36, 7.0.30, 7.1.17 and 7.2.5

The PHP developers recently released versions 5.6.36, 7.0.30, 7.1.17, and 7.2.5 that fix several bugs. We’ve upgraded the PHP 5.6, 7.0, 7.1, and 7.2 series on our servers as a result.

These changes should not be noticeable, but as always, don’t hesitate to contact us if you have any trouble.

Apache 2.4 web server upgrade (complete)

Update May 3, 2018: The change described below is complete on all servers.

Over the next few days, we’ll be updating the software used on each web server from the Apache 2.2 series to the 2.4 series.

Customers should not notice any changes or downtime. We’re mentioning it here just so that customers who do notice a change for some reason will know about it.

While the Apache 2.4 series has some changes and new features, we’ve intentionally kept things compatible with older versions. In particular, we’re using mod_access_compat to ensure that existing “Allow / Deny” authorization directives work, and we’re using SSILegacyExprParser on to ensure that existing Server Side Includes work.

The Apache 2.4 series brings changes we’re using to improve our customers’ websites. For example, we’re already using OCSP stapling to speed up the initial connection to SSL sites in many browsers, and in the future we’ll be adding support for the newer HTTP/2 protocol. Neither of these were possible with older versions of Apache.

As always, don’t hesitate to contact us if you have any trouble.

Wildcard Let’s Encrypt certificates now available

Let’s Encrypt recently started offering wildcard SSL certificates that work with any subdomain, without forcing you to get a new SSL certificate every time you change the hostnames you use.

If we host your site’s DNS nameservers (which is true for almost all of our hosting customers), we can now automatically provide you with a wildcard certificate, for free. We’ve already updated every existing Let’s Encrypt certificate to be a wildcard wherever possible.

If you’re still paying GoDaddy $349.99 a year for a wildcard SSL certificate, or paying Network Solutions $579 a year for it, now might be a good time to switch to our service. 😉 (In the last week, we’ve provided several million dollars worth of wildcard certificates to our customers even at GoDaddy’s introductory prices. You’re welcome!)

We’re using Let’s Encrypt wildcard certificates ourselves, too

We’re now also using these certificates on everything related to our own services, too, including our website, blog, FTP servers, and mail servers.

Almost all customers shouldn’t notice any change, but if you use secure connections with old or unusual programs that don’t handle SSL connections properly, you might be asked to “accept” the new certificate.

Read the rest of this entry »

PHP 7.2 series now available

We’re now providing support for PHP 7.2 (in addition to the 5.6, 7.0 and 7.1 series), so PHP 7.2.4 is available in our control panel.

We believe it’s stable (it’s used for the blog you’re reading now), but we don’t yet recommend it for most customers. It’s fairly new and some third-party scripts are not yet compatible with it. If you want to try it anyway:

  1. First, update your site’s PHP scripts, including WordPress, Joomla, any plugins or themes you use, and so on
  2. Login to our My Account control panel
  3. Click PHP Settings
  4. Click PHP 7.2 series
  5. Click Save Settings

After updating, test your site carefully to make sure there aren’t any problems.

By the way, if all this seems confusing, we have a page explaining more about PHP versions and updates.

PHP 7.1 is now the default for new accounts

The somewhat older PHP 7.1 series has been out long enough that all modern script software should be compatible with it. Because of that, we’re making PHP 7.1 the default for new customers.

We haven’t changed the version for any existing accounts, but we recommend that all customers use at least PHP 7.1 if possible (the instructions above explain how to choose the version your site uses). PHP 7.1 is slightly faster than PHP 7.0 and almost twice as fast as PHP 5. If you care about your site’s speed (and you should), always use the newest version of PHP that’s compatible with your scripts.