PHP versions < 5.6 rebuilt (but please don't use them any more)

Although we haven’t offered the long-obsolete PHP 5.5 (and earlier) series to new customers for some time, some customers who signed up long ago are still using this version (or even earlier versions), despite our nagging you to upgrade 🙂

For those customers still using PHP 5.5 or earlier despite the nagging, this is just a quick note that we’ve “rebuilt” older versions of PHP for technical reasons to allow them to keep running on our systems. They now use slightly newer versions of various libraries, including libxml, FreeType, ImageMagick, MySQL, and OpenSSL, and they no longer support some old obsolete libraries, such as T1Lib. The rebuilt version will be deployed on all our servers within the next few hours.

These changes should not be noticeable. In the unlikely event you experience any trouble, don’t hesitate to contact us.

All that said, nobody should be using PHP 5.5 or earlier any more. Old versions have hundreds of bugs that will never be fixed, and are slower than newer versions. If you’re using an old version, please upgrade to at least 5.6, and preferably 7.0 or later.

First, make sure you’re using the latest available versions of any PHP scripts you’ve installed, then:

  1. Login to our “My Account” control panel.
  2. Click PHP Settings.
  3. Click PHP 7.0 series, then Save Settings.

Then test your site. It will probably work fine, and you’ll be all set for years.

If it doesn’t work, you can try the slightly older, but still supported, PHP 5.6 series.

If the 5.6 series doesn’t work, either, it means the PHP code in a script you’ve installed is incompatible with modern versions of PHP and needs updating. You can switch back to the older version again to get things working immediately, but old versions will be removed from our servers in the future, so that’s not a long-term fix. You should contact the person who wrote or provided your PHP scripts, and that person should be able to fix this for you.